Jump to content
JMailuhu

Install Mavericks Toshiba C55

Recommended Posts

Hi i'm trying to install Mavericks on my Toshiba C55, but i cannot boot into OSX. When i boot with -v -x GraphicsEnabler=no i see that i get a error with some SMC doesn't load and HPETs CPU (s) configured incorrectly.

I tried to bypass that with the terminal command; mv /Volumes/"..."/System/Library/Extensions/AppleIntelCPU* /Volumes/"...."/ and at next boot it says at that line "AppleIntelCPUPowerManagement not found" or something like that, i guess because i moved it from folder with command.

 

It still does not go past this boot. I did some minor changes in "Customize" USB installer like choosing SMbios MacBookPro 8.1 and keeping the Nvidia driver default instead of choosing IGP. What would be my best option to go from here? Maybe clean install without customizations other than SMBios?

 

A few years back i succesfully ran SnowLeopard iATKOS so i'm not totally new to Hackintosh.

If anyone with similar specs know some config that would save me alot of time reconfiguring etc. would  appreciate it.

 

 

Toshiba Satellite C55 A-1D7

CPU: i5-3230M 2,6GHz

RAM: 8GB DDR3

GPU: Nvidia GeForce GT-710M 1GB DDR3 & Intel HD 4000 series

WIFI / LAN: Atheros AR946x & Atheros AR8172/8176/8178 PCI-E Fast Ethernet (NDIS 6.30)

SOUND: IDT High Definition Audio (Realtek??)

BLUETOOTH: Atheros AR3012 Bluetooth 4.0

BIOS: AHCI mode, VT-x in bios off, Legacy Enabled, 

Share this post


Link to post
Share on other sites

I'll try and see if i can upload a  picture with the boot info, report back asap.

Share this post


Link to post
Share on other sites

New install, enabled "Disabler" in chipset setting and SMBios: MacBookPro 6.1

After DSMOS screen turns black and nothing happens

 

Screenshot1: https://drive.google.com/open?id=1VgVfibqxxJyZDv6g-E7AxIsPsp0yz6YI

 

tried booting -s + grafix replace all

 

After booting with: -v RootCPUID=1

 

i get a little further but now IOPlatformPlugInUtill error and Bluetooth error

 

Screenshot2: https://drive.google.com/open?id=1-T1m_GAk68HRxRO4nXU7-M1RVh3t-zsn

 

So i should stick with the first setup where i get no errors and the black screen, going to test with GraphicsEnabler=no and IGPEnabler=Yes in usb install customization menu, because i think the black screen is gpu related.. Any thoughts?

Share this post


Link to post
Share on other sites

Update: Installed for 3rd time using following customization:

  • IGP Enabler=Yes + Move Nvidia GPU Extensions
  • Audio kEXT + Network kEXT
  • FakeSMC
  • SMBios MacPro 8.1
  • dart=0, Eth=Yes, npci=0x2000, UseKernelCache=Yes
  • Niresh Fixed Chipset
  • Disabler + NullCPUPowerManagement
  • OSX Files
  • Trim SSD + USB 3.0
  • Chameleon Standard

First boot: KernelPanic IntelCPUPowerManagement

Second boot: -x boots into safe-mode (thats a first), setup username, let OSX-Installer fix kEXT cache's and optimizations.

Third boot: -v stops after IOBluetooth stuff

 

While booting -x and being in safemode, i have no WiFi, No Ethernet and no Sound, but Bleutooth works (whereas with normal boot it hangs when loading BT)

I'm not sure what to do next, i've tried most things..

Got anything on this @Niresh?

Share this post


Link to post
Share on other sites

@JMailuhu Use

sudo grafix replace all

that will replace all backup kexts (If they were backuped) I think GT 710 does not need web drivers.

GraphicsEnabler=Yes is needed.

Try to Install and Setup clover. Chameleon development has been halted.

 

Why did you Move Nvidia GPU Extensions?

 

If possible replace the FakeSMC with FakeSMC Stable

Share this post


Link to post
Share on other sites

@Niresh I'll try that! I moved the Nvidia Drivers because i thought i had read that i should move any Nvidia related content if i want to use IGPEnabled=Yes instead since i get a black screen using Nvidia drivers, and Intel works fine. Apparently i was wrong..

I will get another usbflashdrive tomorrow to store kEXT files since i do not have another one for MultiBeast and drivers kEXT i collected, and that FakeSMC_Stable.

Share this post


Link to post
Share on other sites

@Niresh I know, i've got a Intel HD 4000 onboard IGP, thats why i used that one instead of Nvidia / GraphicsEnabler since it doesnt seem to boot with those settings.

 

I just did "-s grafix replace all" to no avail. It placed files back in S/L/E but still doesn't boot and no error or panic is given with -verbose. I'm going to try reinstall, now clover instead of chameleon.

 

Any opinion on what i should tick @ customization? I don't want to get mixed up with GraphicsEnabled / IGP. Is the custolist i posted in post #4 actually good?

 

Share this post


Link to post
Share on other sites

@Niresh I finally succeded with booting Mavericks without any bootflag input.

I have sound, and i can access my Windows Partition to access kEXT files.

Now i just need to find some kEXT for my Ethernet /WiFi since the ones provided with MultiBeast do not work, and how i can boot without my USB inserted (ill check of EasyBCD will work)

 

I went by this customization config:

 

  • Clover Standard (Still boots into Chameleon)
  • IGP Enabler=Yes + Backup All GPU Extensions
  • Audio kEXT + Network kEXT
  • FakeSMC & CPU Plugins
  • SMBios MacPro 6.1
  • dart=0, Ethernet=Yes, npci=0x2000
  • Niresh Fixed Chipset
  • Disabler, NullCPUPowerManagement, JMicron SATA Fix
  • OSX Files
  • USB 3.0

Anyway thanks for the help, much appreciated and keep up the amazing work you're doing!

Share this post


Link to post
Share on other sites

@NireshUpdate: 

 

I have successfully updated to 10.9.5 (with Combo) and backup of old S/L/"E" files and Mach_kernel which i replaced with the terminal cp/mv commands. Everything works except for Ethernet, but i use WiFi anyway, and the Nvidia card since web drivers say my computer is not compatible and i'm not in the mood of editing the .pkg file with Auxillery.

After lots of research i also fixed the Intel HD 4000 QE/CI by putting IntelGFX* back into Extensions folder and repaired permissions and editing my Chameleon.boot.plist with the following lines:

 

<key>InjectIntel-ig</key>
<string>03006601</string>    
<key>IntelCapriFB</key>
<string>3</string>

 

" About this Mac"  says i got 1024VRAM and everything runs butter smooth now without flickering.

 

I hope this thread can be useful for other people for setting up their Hackintosh with similar specs, and how to solve the QE/CI problems.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...