Jump to content
James Moore

MSI Radeon HD 7770 Ghz edition

Recommended Posts

Hey guys. New to hackintoshing. I've had some experience with getting installs working in virtual box on other systems before but that's it.

I successfully got the Niresh mavericks 10.9 distro installed to my pc after some fiddling around with partition issues.

Now I'm having an issue booting to the os after install. I get a "memory allocation error! 0xdeadbeef, Size: 0x0, File: ati.c, Line: 1772" error.

I tried using -v -x and GraphicsEnabler=No, the latter killed the error but causes the os to reboot over and over after loading some initial files. I never actually get to the boot loader menu.

I also tried changing init display in bios to onchipvga which gets me to the boot loader but then reboots itself over and over even when using the same boot flags.

My specs are

Gigabyte GA-MA790GPT-UD3H

AMD Phenom II x4 965 black edition

6gb ram. It's gskill not sure model

MSI Radeon HD 7770 Ghz edition

I'm at a loss at this point on how to get this working properly. I have windows 7 ultimate on same pc different hdd and hfs+ drivers so I can use windows to modify files if need be. I can also take videos or screenshots with my iphone if I need to.

Any ideas on how I can get this running?

Share this post

Link to post
Share on other sites

I have attached a photo of the beginning of verbose output. It looks like both my onboard video and my video card are recognized in the boot process. However once I get to "starting Darwin x86_x64" it displays the boot args and then reboots itself automatically. Now mind you this is all only showing if I use the onboard video as the init display in bios.

I can share what boot args shows. But I doubt it's helpful as it shows the flags used by bootloader and the flags I set. Also all this info is only displayed if I try booting to safe mode. Single user mode and normal boot fail earlier on, likely for same reasons.

I think Niresh auto installs chameleon bootloader. So I'm curious if trying a different one like clover may help. I'm also not sure if dsdt would be necessary in my case or some device id injection or something.

Any help would be appreciated. If any additional info is necessary let me know.

Share this post

Link to post
Share on other sites

Hrmm picture never uploaded correctly from my phone. Oh well I found out completely disabling onboard graphics entirely allows me to reach boot loader with video card, however I still get the memory allocation error. If I use GraphicsEnabler=No then it will load darwin but never start it, it just reboots the pc at the end of the loading process. At this point I'm still at a loss because I'm not sure what I would need to do to get this working.

Share this post

Link to post
Share on other sites

So I got everything working. I reinstalled a third time. But this time I set cpus=4 and I removed dart=0 and added pcirootuid=1.

I downloaded the radeon7000controller kexts on this site and installed them. Used GraphicsEnabler=No. However the radeonaccelerator kexts doesn't load at startup and errors out. I can still boot. But I noticed in safari I have glitchy graphics and artifacts. I also have no sound via hdmi. Anyone know what I need to do to fix these two things?

I also have issues with putting the computer to sleep and restarting. The pc will shutdown the os and run Mach reboot but hangs. On sleep the hard disk spins down but that's it. Screen goes black with just mouse cursor and pressing any key redisplays the login screen.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.

    $22.66 of $100.00 goal reached.
    Donate Now