Jump to content
sjpro

SSD Partition Problems - Spinning Wheel

Recommended Posts

Hi all,

i have had a system running successfully for a few months now, everything perfect. 

However, one thing that does keep happening is errors with the SSD I’m using, more specifically if I have to do a hard reboot.

if I power down during active Mac or lose power without shutting down properly I have to reinstall Mojave fully by formatting SSD then time machine restore.

For some reason the partition gets corrupt and I can’t fix it with the usual disk util or command line processes I have found online. 

Has anyone come across this issue as I can’t tell whether it’s an SSD hardware failure or something to do with the way the OSX works?

I know one thing, a normal HDD seems to work fine.

 

 

 

Share this post


Link to post
Share on other sites

@sjpro Yes i had this error once, with an Intel SSD, the problem was TRIM, after not enabling TRIM the error was fixed. Try it disable TRIM. Let me know if it fixes the issue.

Share this post


Link to post
Share on other sites
1 hour ago, Niresh said:

@sjpro Yes i had this error once, with an Intel SSD, the problem was TRIM, after not enabling TRIM the error was fixed. Try it disable TRIM. Let me know if it fixes the issue.

Thank you. Niresh would your Distro have trim enabled by default on a fresh installation?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...