Jump to content
Roshith Balendran

Niresh Mavericks works like a breeze.!!! No Wifi,Sound and Multiboot with Windows fails miserably...! Needs your help desperately...

Recommended Posts

Hi Team Niresh. First of all...


Thank You. Thank You. Thank You.!!! A Big Thank you to you guys..!!!



I was trying to install a Hackintosh for a week. After surfing a while I understood the limitations of an AMD CPU in a Hackintosh Build.!


I was crestfallen.! My carefully planned upgrade after a lot of research was a waste.???


Then I heard about Niresh, and have been trying to install Niresh Mavericks for the last week.


I have successfully managed to install Mavericks using this Link. http://cyanlabs.co.uk/tutorials/os-x-10-9-on-gigabyte-990fxa 


(Forgive me, If posting links are against rules. But I need to make sure that you understand my problem)



I have managed to Install Niresh Mavericks without any trouble and my CPU and GPU detected on First Boot.!


FX 6100 is detected as a Hex Core Xeon Processor, GPU detected fine. But the FSB of RAM has gone down from 1600MHz to 1333MHz. Its 1600 Mhz in BIOS. Don't know what happened.


I'm an iOS App Developement Trainee. So my main focus will be using Xcode and may be a bit Photoshop. 


I have installed the latest build of XCode, 5.1.1 from a dmg file. And it has run without any trouble. So far good.


Now to my Problems.


I have a TP-Link TL-WN721N Wireless Adapter which I use to connect to my Wifi Router. My Ethernet Port has been fried in a Lightning surge last year.


And I have no plan to risk my build to a wired Internet connection ever again. So Ethernet is out of the picture.


My WiFi adapter is not detected. So does the Sound. I use HDMI Audio out, and it doesnt work. But If I plug the 3.5mm Jack into my Motherboard, I can hear sound but with a lot of background noise. (Like an FM Station)


But my biggest problem is Wifi adapter. I'm so desperate for internet connection. And I have found Drivers for other TP-Link variants, like TL-WN821N here.


I'm new to iOS app developement and I cant clear my doubts without Internet Connectivity. 


Could you provide me with a Driver. Similar variants of TP-Link Wifi adapters have drivers here. Please help me as well.



Another trouble for me is Dual Booting OSX and Windows.


I'l explain what I have done so far step by step. Tell me what I did wrong and what I should do next.


* Created a Bootable Image of Niresh Mavericks (Taken from Kickass Torrents) using Win32 Disk Imager from Windows 7


* Unplugged my other 2 Hard Drives, Wifi Adapter and Camera.


* Booted using the flags "amdfx GraphicsEnabler=No PCIRootUID=1 -v "


* Using the Disk Utilities, Partitioned the 200 GB HDD into 2 partitions. Erased the entire Drive first. Then created 2 partitions, 120 GB MS-DOS (FAT) and 80 GB Mac OS Extented (Journaled). Selected MBR from options and Click apply.


* Rebooted using Windows 7 Ultimate bootable image(Non UEFI Version selected) and installed it as usual. Completed Installation and Rebooted.


* Again booted into Niresh Mavericks using the Flags  "amdfx GraphicsEnabler=No PCIRootUID=1 -v "


* Selected the Second HDD partition and unchecked GraphicsEnabler from Customize option.


* Completed Installation of Mavericks as per on screen instructions. Waited for installer to configure and rebuild necessary stuff.


*CPU and GPU detected, Booted into 1080p resolution. Installed XCode 5.1.1 without any hiccups.


* XCode works without any trouble, but still no WiFi.


* Installed Chamaleon Wizard, opened it, Selected "Boot0HFS" and clicked install.


* Now Mavericks boot without the Bootable image or the flags.


* Tried "All in One Ethernet Solution", Wifi still not detected.


* Tried to update AMD Kernel using the file "AMD 10.9-10.9.1-10.9.2 kernel, with SSE3 and opemu Version R6".


* The instruction was precisely this:



"Next select “Go†on the menu bar, and then “Go to folder†and then “/â€, This will put you to the root of the OS X Partition, Now we need to replace the mach_kernel with the download mach_kernel file. Simply copy and paste and confirm the authentication.
Now we need to copy the downloaded “System.kext†to “/System/Library/Extensions/â€, once this is done you will most likely get some errors don’t panic!.
Now we load “Kext Wizard†(installed with niresh) and select “Repair†and “Rebuild†under the â€/System/Library/Extensions/â€.
Once “Kext Wizard†is done, Click the “Apple icon†in the “Menu Bar†and select “Software Update†and “Update Allâ€, This will take a little while, When asked to reboot say yes.
Now your system should reboot and you should be back at OS X at 10.9.1 instead of 10.9.0."
* The problem is, when I tried to replace the mach_kernel, error occurs. The error message is "Can't replace because mach_kernel file is hidden".
* I don't know how to unhide it, So I skipped the rest of the steps in blue letters.
After this everything is a messy experiment. I was using a a different guide for dual booting. Sadly I lost it in the bunch of links.
My Plan was to reboot using Windows bootable image, Repair start up, reboot into mac using some flags and to edit a .plist file or something like that.
But System Repair is not working. I have tried
bootrec /RebuildBcd
bootrec /FixMbr
bootrec /FixBoot
Didn't work either. No Windows installations detected and bunch of errors.
I don't have internet in Mac and I can't boot into Windows.
What should I do to get WiFi and sound working. And also guide me how to Dual Boot Mac and Windows Step By Step.



Its would make my life different, If got the kexts for WiFi and Audio, and step by step guide to Dual Booting OSX and Windows 7.






My Desktop Build:


AMD FX 6100 3.3 Ghz 

Asus M5A97 MoBo

ATI Radeon HD 6850 GPU *1 GB GDDR5*

GSkill RipJawsX 4GBx1 DDR3 RAM *1600Mhz*

Cooler Master Hyper 212 Evo

Cooler Master Thermal Fusion 400

Cooler Master GX 550W PSU (PFC=Yes)

Iball Nirantar UPS (1000 VA, 600W, Simulated Sine wave, Maximum Transfer Time:14ms)

Logitech G100 Gaming Combo

Razer Goliathus Mouse Pad

Microsoft XBox Controller

Samsung 200 GB 7200 RPM HDD *Boot Drive*

WD Green2.0 TB 5400 RPM HDD *Storage*

WD Green 3.0 TB 5400 RPM HDD *Storage*

AOC 22" e2243Fw2k LED Monitor *HDMI*

Logitech C110 Webcam

Altec Lansing 2.1 Speakers *HDMI Audio Out*

LianLi Lancool Dragonlord Cabinet


TP-Link TD-W8951ND Wireless Router

TP-Link TL-WN721N Wireless Adapter


Google Nexus 7 Tablet

Amazon Kindle Paperwhite

  • Like 1

Share this post

Link to post
Share on other sites

@Roshith Balendran Thanks for the amazing explanation in this post

Probably you cant find drivers to TL-WN721N 

thats going to be a problem if you still need internet access you could try to buy cheaper mac supported USB Ethernet or WiFi Devices from Ebay

While installing mavericks you could have changed some bios settings so probably reverting settings may fix the problems  (Example SATA to AHCI)

but once i was not able to fix the problem so i need to reinstall windows again (Personal Experience)

Using a Proper SMBIOS Will Fix Ram FSB Issue ( Use The App Champlist Better Go With MacPro 3)


Now to Replace Kernel Follow These Step

Download and Open Application "Desktop Utility"

Using That You can View Hidden Files (The App Will Be Hooked in Menu Bar"

Now Rename mach_kernel as mach_kernel.bak

copy and paste the new kernel

I also give terminal commands but you need to be little familiar with it


If you need assistance in purchasing WiFi or Ethernet Adapters Contact Me Again 


  • Like 3

Share this post

Link to post
Share on other sites

Niresh explained you well. The problem I see from here is (Numbering is native):


1. Formatting whole Disk using OSX-Installer and then installing Windows on this Disk can be easy in theory but messy in practice.

    So, sadly you may have to start with windows installation again.


2. For sound, you need to install VooDooHDA.kext (search it) using kext wizard, and then reduce iGain (VooDoo pref pane) to 0 to get rid of FM effect (???).


3. For wifi, if your adapter is v4 then use this or it wont work (buy nano wifi adapter)



4. RAM issue is not by OSX but your BIOS. I am sure its a setting in BIOS to OC the RAM at 1600 or it will show 1333 default, and you have to OC 1600 before installing OSX, or it may crash/freeze/KP if you OC to 1600 after installing.

  • Like 3

Share this post

Link to post
Share on other sites

Thank you Niresh and Aman for the quick replies...


I didn't manage to make all those changes, but life has got much better now.


I installed VooDooHDA, which I got from this website. I managed to make the sound working by making the output as Rear Green Panel (Green rear jack in MoBo) instead of HDMI. iGain has already been zero, so no more noise.


Its a minor inconvenience. But is there a way to make Audio through HDMI work.???


The thing is, my monitor has 2 HDMI ports. I use 1st for my PC and second for my Airtel DTH. So if I settle for Audio jack every time I want to watch DTH.

I tried to set the Audio out through HDMI. But no use. I'l include screenshots later.


About updating AMD Kernel, I have installed the Desktop Utility, unhided mach_kernel, renamed it and added the new file. I have also replaced the System.Kext in System/Library/Extentions/


I have repaired and rebuilded using kext wizard. Done.!


Next step in the guide I followed was to click software update>Update all. 


But when I click software update, the update windows goes all grayed out.! Is it because of no internet connection.?


I was supposed to update and reboot for the OSX to update to 10.9.1.



And the Dual boot was insanely simple. All these time, I selected Windows partition instead of System reserved from Niresh boot loader. Now windows boot fine after installing Boot0hfs from Chamaleon bootloader.


Thank you again.

Share this post

Link to post
Share on other sites

Niresh and Aman, I need a USB Wifi Adapter, which is tested and working fine in Mavericks. And a cheap one too as I already own a Wifi Adapter.






Please use these two websites. I don't usually buy stuff from Ebay.in


And I presume Mavericks will work just fine in an SSD. Planning to buy a 120GB Samsung 840 Evo SSD (SATA III) as Dual Boot Drive. Please have a look at sound through HDMI issue as well..


Thank you for your patience.

Share this post

Link to post
Share on other sites

Just to clarify, If I use a PCI Wifi Card, Mavericks will support it without any kexts.? Will it be identified as an Airport.???


ie, if I use the TP-LINK TL-WN851ND Wireless N PCI Adapter Nic, I won't have to search for kexts next time I upgrade or install a newer OSX version. Right..??? 

Share this post

Link to post
Share on other sites

You will not get support out of box from OSX for PCI wifi card, but the kext is official from manufacturer itself, and it Airport will work with it.

Yes every time you upgrade/Update, this kext will function as usual till Apple doesnt break something important in new OS and manufacturer doesn't release a new Kext.

But chances for this is very rare.

Edited by Aman

Share this post

Link to post
Share on other sites

Good morning to all, first to all, thanks for your patience and please, forgive me for my english, I´m from Colombia and my english need practice.

Well, my problems are the next:

1. My multiboot isn't work, I installed Windows 8 and later I installed Mavericks 10.9 and the only way to choose which OS I want to start is with the Mavericks's DVD inserted, if anyone can help me I would appreciate. I used Chameleon 2.3 svn r2588 to trying install the multiboot but nothing.

2. My Graphics is working half, I have EVGA Nvidia Geforce GTX 750 SC (GDDR5 1GB), in system informations show me that:


             Type: GPU

             Bus: PCIe

             PCIe Lane Width: x16

             VRAM (Total): 3 MB

             Vendor: NVIDIA (0x10de)

             Device ID: 0x1381

             Revision ID: 0x00a2

             Kernel Extension Info: No Kext Loaded



             Resolution: 1024 x 768

             Pixel Depth: 32-Bit Color (ARGB8888)

             Main Display: Yes

             Mirror: Off

             Online: Yes

The only resolutions is 1024x768 when my monitor support 1440x900

3. My Audio Kext isn't work, I have ALC662

My System is:

MOBO: Asrock H61M-VG3

Graphics: EVGA Nvidia Geforce GTX 750 1GB GDDR5 (Is NOT the ti)

Memory: 6GB RAM 1333 MHz DDR3

Memory Slots:


  ECC: Disabled


BANK 0/ChannelA-DIMM0:


  Size: 2 GB

  Type: DDR3

  Speed: 1333 MHz

  Status: OK

  Manufacturer: PDP Systems

  Part Number: PSD32G13332

  Serial Number: 0


BANK 2/ChannelB-DIMM0:


  Size: 4 GB

  Type: DDR3

  Speed: 1333 MHz

  Status: OK

  Manufacturer: NoName

  Part Number: N/A

  Serial Number: 0

Processor: Intel Core i5 3,19GHz

Thanks for your help

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...