Jump to content
magicmarcus

How to boot with HIDPI custom resolution and default speaker

Recommended Posts

Hi i'm running Mac OS Mojave 10.14.1 hackintosh and basically whenever i boot into mac os i always have to manually select the speaker as my own audio device so the sound will play through it can you help me make it the default audio device right from booting. I am using Voodoo HDA 2.9.0. I also created a custom HIDPI resolution because the native 1920x1080 resolution was too tiny right now i'm using a scaled down 1600x900 hidpi resolution. When i boot into mac os i always have to select it after i login with the RDM app because it doesn't show in systemspref/displays even when i click on scaled with the command button. I put the RDM app in the login items so it starts with mac os but it still does not use the hidpi resolution as default it changes to a non-hidpi 1600x900 resolution. Any help would be appreciated.

Share this post


Link to post
Share on other sites

@Niresh thanks for the reply

 

heres my setup

Lenovo ideapad 310-i5isk

Intel Core i7 6500U @ 2.50GHz
Skylake-U/Y 14nm Technology

20GB DDR4 RAM(16GB on macOS)

1TB Crucial SSD

Intel HD Graphics 520\nVidia GeForce 920MX

Share this post


Link to post
Share on other sites

@magicmarcus If you have installed voodoohda through niresh mojave , drag and drop VoodooSettingsLoader.app into Login Items

https://www.macworld.com/article/2047747/take-control-of-startup-and-login-items.html

Also Niresh Mojave installer modify VoodooHDA.kext, try to backup and Install from SourceForge the original version.

 

For Graphics Which kext are you using to tweak?

 

Have you tried AppleALC.kext instead of VoodooHDA?

Share this post


Link to post
Share on other sites

I've tried most of the things you just listed i have put voodoosettingsloader into login items and also tried deleting the voodoohda.kext that came with installation and downloading it from sourceforge but i still get the same problem. I even reinstalled and chose AppleHDADisabler but i still get this problem.

 

For the scaled down hidpi graphics i didn't use a kext i followed this guide https://www.tonymacx86.com/threads/adding-using-hidpi-custom-resolutions.133254/ basically its creating a display plist file with the custom resolution in a folder with my displayvendor id.

 

I haven't tried AppleALC how do i get it to work with my audio its a coxenant smart audio.

Share this post


Link to post
Share on other sites

@Niresh I tried to install the latest version of AppleALC to see if it would fix the issue but its not working my audio tray icon is grey and theres no outputs in systempref/sounds. I've tried layout-id 3, 28, 30, 33 but theres still no sound with applealc can you help?

Share this post


Link to post
Share on other sites

@Niresh I'm not quite sure how to go about creating a bug report directly in the repository every debugging script i've googled is a full system debugging report can you help?

17 hours ago, Niresh said:

bug report

 

Share this post


Link to post
Share on other sites

@Niresh Can you help please i feel like AppleALC may alos fix my bluetooth headphones/speakers not playing no sound aswell. Also how about booting with the hidpi screen resolution can you help me with that?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...