Disable ADBlock Extension If you have.
Mojave installation boot restart loop and other faults - Niresh Mojave Help Forum - Hackintosh Zone Jump to content
magicmarcus

Mojave installation boot restart loop and other faults

Recommended Posts

Hi i just installed mojave on my laptop this is the first hackintosh distro that i have gotten to work on a laptop.  I have a few problems when i boot mojave without the installation USB i notice it goes into a restart loop everytime. I also have hardware problems my audio and wifi is not working but bluetooth is working. I tried to boot into windows to check my audio driver type but every-time i select windows in clover it states:

 

'An operating system wasn't found. Try disconnecting any drives that don't contain an operating system. Press any key to restart'

 

Can you help me mount Windows to clover so i can dual boot? Can you also help me with what drivers i can use to get audio and wifi compatibility? The other problem i have is that i can't boot Mojave without the installation USB it seems.

 

 

Share this post


Link to post
Share on other sites

@magicmarcus Also i don't see the partition that Mojave is installed on the deskop or finder is that part of the problem? I have updated clover to the latest version. 

Share this post


Link to post
Share on other sites

Another problem is im getting lags and graphic defects when using chrome and safari 

Share this post


Link to post
Share on other sites

Sorry for the long entry but I updated clover and I still can’t boot Windows but now I can’t boot Mojave either I checked the boot options and there’s no commands it seemed to boot with the original boot commands anyone know it included -dart or something

Share this post


Link to post
Share on other sites

@magicmarcus 

Have you tried Installing Clover EFI?

Share this post


Link to post
Share on other sites

I’ve installed clover  and it freezes on applelogo when booting when I boot verbose mood it seems to be stuck on the row of plus signs I have clover comfigurator is that the same? @Niresh

Share this post


Link to post
Share on other sites

@Niresh I installed clover but it was installed on the Macintosh HD not on the efi partition i then mounted the EFI partition and dragged the EFI folder manually to it

Share this post


Link to post
Share on other sites

@Niresh I was able to edit EFI for it to boot from Windows and i also got the sound to work but i still don't have WiFi connectivity and i have tried everything i cant get updated clover to boot mojave i still have to use the USB

Share this post


Link to post
Share on other sites

@Niresh My WiFi is atheros QCA9377 is there any kexts i can install to get it to work?

Share this post


Link to post
Share on other sites

Ok i finally was able to fully accelerate the Intel HD Graphics and fixed the restart loop when it was at End random seed ++++++. I can now boot with Clover without USB basically the problem was a memory mapping issue i followed the instructions on https://hackintosher.com/forums/thread/mapping-ram-and-dimm-slots-on-a-hackintosh-with-clover-smbios.365/ and just like magic it worked :D. Now my only problem is WiFi issue and battery percentage always showing as low any help would be appreciated

  • Like 1

Share this post


Link to post
Share on other sites

what did you do exactly to make boot wotout the loop?

Share this post


Link to post
Share on other sites

@erwinmexicotudueño Basically i had to manually add the RAM in SMBIOS in my config.plist file because it wasn't being mapped properly causing the error. I'm on a laptop and i have 20GB of RAM but 16gb of it was recently installed and the rest is installed on the motherboard i think. So i had to add the newly installed RAM details with clover configurator starting with the slot number, size, frequency (mhz), vendor, type (DDR4) and even part and serial number and i then edited the exact parameters with textedit.  

 

heres the step by step guide: https://hackintosher.com/forums/thread/mapping-ram-and-dimm-slots-on-a-hackintosh-with-clover-smbios.365/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.66 of $100.00 goal reached.
    Donate Now
  • Forum Statistics

    • Total Topics
      9,586
    • Total Posts
      29,551
  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.66 of $100.00 goal reached.
    Donate Now
  • Topics

×