Disable ADBlock Extension If you have.
GioScreenLockState 3 - Hackintosh Sierra - Hackintosh Zone Jump to content
Shinkson47

GioScreenLockState 3

Recommended Posts

My hackintosh has been running Sierra happily for over a year, however something has suddenly started to prevent my machine from booting.

 

In the lead up, i was configuring a new network share - and the last thing i did was hit switch user. I hadn't done this before on this machine, and doing so gave me a black screen.

 

After a while, it was clear that Mac OS had  hung, so i force restarted - and ever since i have not been able to boot. 

 

Verbose mode revealed that the system would hang on gioscreenlockstate 3 whilst booting.

 

I spent some time looking through existing threads, and performing things that have been suggested - everything apart things which require the system to be booted - such as downloading and installing kexts. None of what others have suggested have worked for me, even though it worked for them.

 

Booting in safe mode, nv_disable=1 or with Web drivers makes no difference to the boot, even though other threads suggested that this problem was caused by driver problems and you can boot on default drivers if they're disabled - which i have not been able to successfully do. I've also tried removing my GPU, to see if i could boot with default drivers on my igpu, but it gives the same result.

 

It's worth noting that this extends further than my boot installation - as I've tried to boot into my install USB disk which also gives the same result

 

System specifications:

Processor: Intel Core i3 4170

DGPU: MSI GeForce 1050 Ti

IGPU: Intel HD Graphics 4400

Motherboard: ASRock H81M-DG4

 

SSD 1) Sierra boot disk - 64Gb

SSD 2) Temporary windows installation - 256Gb

 

HDD 1) Extended Mac OS storage and a partition used for a network share 1Tb

 

Any thoughts or suggestions on how i can fix this?

Share this post


Link to post
Share on other sites

@Shinkson47 

Disable IGPU on BIOS

Install Whatevergreen.kext with Lilu.kext 

Repair Kext Permissions /S/L/E & /L/E.

 

Try to use iMac 14,2 SMBIOS.

Share this post


Link to post
Share on other sites

Hi Niresh!

 

My iGPU was already disabled - this made no difference

My system definition was already iMac 14,2

 

I don't know much about repairing permissions, but i ran chmod in -s in /S*/L*/E* and /L*/E*, however sudo was not possible in single user

 

after that, chown refused to run because the partition is apparently read only. 

 

I've spent some time trying to install Whatevergreen.kext and Lilu.kext, i haven't been able to since i can't boot to use a utility I've tried copying them over in -s, however the system is refusing to mount another drive with 'mount -t msdos /dev/disk1s1 /disk1', either with a bunch of mount_msdos errors or with 'unsupported sector size (0)' and copying isn't possible - again because the partition is apparently read only. 

 

@Niresh 

I also tried to copy the kexts to the Mac disk using TransMac, however it too said the disk was read only.

Share this post


Link to post
Share on other sites

@Shinkson47 Boot from Niresh Sierra, Have Whatevergreen.kext with Lilu.kext on a USB, Use the terminal to copy & repair permission.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $18.27 of $100.00 goal reached.
    Donate Now
  • Forum Statistics

    • Total Topics
      9,573
    • Total Posts
      29,443
  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $18.27 of $100.00 goal reached.
    Donate Now
  • Topics

×