Jump to content
GeorgettaCZ

AMD 7650M 1GB - can't get to work on HP 8570p with HS

Recommended Posts

Hallo!

 

I hope I chose the correct forum section. If not, I apologise, and yes please, move it to the correct place. 

 

Now to my problem. I have HP 8570p with i7-3540M Ivy Bridge, 8GB RAM@1600MHz, AMD 7650M 1GB, Apple SSD 128GB + WD Black 500GB HDD instead of DVD, 1600x900 screen. It seems that the intel HD4000 is completely disabled, I can't see it neither in Windows nor in Ubuntu nor in macOS. I successfully installed High Sierra and all is working fine except for the graphics. It shows only Basic display with 5MB.

Here is what I achieved so far:

1. temporally installed Win 7 to grab my 1600x900 screen EDID raw data - this is what I got:

00FFFFFF FFFFFF00 06AFEE11 00000000 00120104 90221378 02E4E5A0 59579226 0D505400 00000101 01010101 01010101 01010101 01016432 40966284 3230402A A40058C1 10000018 98214096 62843230 402AA400 58C11000 00180000 00000000 00000000 00000000 00000000 00000002 000C49F9 0A3C661B 2A396620 20200001

2. temporally installed Ubuntu 18.x.x to grab my GPU ROM file - successfully dumped 65kB vbios.rom

3. Get AMD FrameBufferUtility (AMDFBU)

- inserted my vbios.rom

- recognised my PCI ID 1002:6841 from vbios and in AMD6000Controller with 5 video outputs (LVDS, DP, DP, DP high res, VGA), suggested to use Pondweed FB, so I disabled one DP and the old VGA

- generated ATI connectors data and ATI connectors patch >>>> put it all in Clover

 

4. Clover 4678
- inserted vbios.rom in ROM folder

- selected Load VBIOS, Patch VBIOS, Inject ATI (RadeonDeInit not selected)

- patched AMD6000Controller with AMDGPU-provided connectors data

- selected InjectEDID and pasted the code above

 

Later I also tried other FBs with LVDS support, tried to disable some video outputs as I don't need them all anyway, tried also AMD7000Controller with added 0x68411002 and some LVDS supporting FBs. Always same result. After restart, AMD 7650M is recognised but still with only 5 MB of VRAM. Any ideas? Please, help.

 

Regards

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...