Jump to content
moppa

HP 800 G1 Touch All In One (Work In Progress)

Recommended Posts

Hi All,

I'm currently trying to get an HP 800 G1 AiO Touch working with High Sierra with reasonable success. I'm a complete Mac newbie so pretty happy so far.

Updated to latest BIOS, used same BIOS settings as HP 8300 guide.

i5-4590s

HD4600 Gfx

 

So far,

Touch working :)

Booting into High Sierra ok. By default identifies as iMac

Graphics show up with 7Mb, Niresh installer suggests using SMBIOS as MacBook Pro settings for Intel Graphics (i think the HD4600 is supported?)

Some screensavers crash system preferences - i think this is to do with the graphics? Changing background seems to distort graphics while it changes.

LAN working

No Sound yet - i possibly done something stupid with VoodooHDA which caused a boot loop so reinstalled.

 

Will update if i get any further!

Share this post


Link to post
Share on other sites
On 9/28/2018 at 11:14 AM, Niresh said:

@moppa Run the following command in terminal, then post the output. here

 


lspci -nn

 

@Niresh Sorry, been a busy few weeks. See below:

 

00:00.0 Class [0600]: Device [8086:0c00] (rev 06)
00:02.0 Class [0300]: Device [8086:0412] (rev 06)
00:03.0 Class [0403]: Device [8086:0c0c] (rev 06)
00:14.0 Class [0c03]: Device [8086:8c31] (rev 04)
00:16.0 Class [0780]: Device [8086:8c3a] (rev 04)
00:16.3 Class [0700]: Device [8086:8c3d] (rev 04)
00:19.0 Class [0200]: Device [8086:153a] (rev 04)
00:1a.0 Class [0c03]: Device [8086:8c2d] (rev 04)
00:1b.0 Class [0403]: Device [8086:8c20] (rev 04)
00:1c.0 Class [0604]: Device [8086:8c10] (rev d4)
00:1c.3 Class [0604]: Device [8086:8c16] (rev d4)
00:1c.4 Class [0604]: Device [8086:8c18] (rev d4)
00:1d.0 Class [0c03]: Device [8086:8c26] (rev 04)
00:1f.0 Class [0601]: Device [8086:8c4e] (rev 04)
00:1f.2 Class [0106]: Device [8086:8c02] (rev 04)
00:1f.3 Class [0c05]: Device [8086:8c22] (rev 04)
02:00.0 Class [0280]: Device [168c:0034] (rev 01)
03:00.0 Class [ff00]: Device [10ec:5249] (rev 01)

 

Video seems very laggy and still have no audio.

Share this post


Link to post
Share on other sites

Install FakePCIID.kext & FakePCIID_Intel_HD_Graphics.kext from this link.

Do not install other kexts from zip.

 

Have you tried Lilu kext with AppleALC.kext for audio

 

Share this post


Link to post
Share on other sites

@Niresh Thanks. Graphics are still very laggy. Even just browsing this site is very choppy. Any further suggestions?

 

I'll have a look at Lilu / AppleALC now :) thanks again!

 

Share this post


Link to post
Share on other sites

@Niresh

I've installed AppleALC now but still no sound. I ran the chmod commands to fix permissions, but on boot i saw failed to load kext applealc.

 

Any ideas?

 

thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...