Jump to content
Sign in to follow this  
Lairi Love Whyte

Device problems after OS 10.9 Niresh install on my HP Pavillion Eliite m9517c

Recommended Posts



My first successful install of 10.9 needs a few tweaks. I have followed you this far and  I am very impressed with the outcome. There are still some things that I don't get and would be very appreciative if you could point me in the right direction. PROBLEM: After install, my webcam, mic, bluetooth and Audio are not present. The display is present but not at any great potential. My iCloud is not functioning (I read it might do that). If anyone can help me with these (kexts) or enlighten me on how I can do it for myself, I would be so very thankful. :)


PC: HP Pavillion Elite m9517c

CPU:  Phenom 9550 Quad (MAC say its a 2.2ghz quad-core Intel Xenon

CHIPSET: GeForce 9100


GRAPHICS: Geforce 9300 GE (256mb)

Audio: Alc 888c chipset HD


I hope I gave enough info...Thank you in advanced!

Share this post

Link to post
Share on other sites

Thank you Aman, for your response! I have Audio and my external drive has shown up. I cant get to enable qe/ci. Ive read how to edit kext but all seems to be vague at how to obtain a kext and write device ID & vendor ID and string without going into terminal.

Share this post

Link to post
Share on other sites

I have a similar setup as you.  I have a 


PC:  HP Pavilion Elite HPE-210f

CPU:  AMD Phenom II X4 945

Chipset:  AMD 785G

Motherboard:  H-RS880-uATX (Aloe) turns out the manufacturer is Foxconn

Graphics:  Nvidia GTX 560 Ti

Audio:  integrated Realtec ALC888S


I have two monitors hooked up to the graphics card.  My primary via HDMI and my smaller secondary via DVI port (with an adapter that turns it into DB9, old monitor).  I read that there would probably be issues with the HDMI port so I disconnected it and installed Niresh 10.9 with my secondary monitor on DVI.  I installed with just "amd64 -v" as my boot flags.  It took me a few installs to try some things out, but this seemed to work best.  I didn't mess with anything in the Customize menu during disk setup.  Once the OS loaded and permissions finished up I was able to reboot.  I was able to get back to the OS is I booted into safe mode using -x, but everything was slow including startup.  I finally narrowed it down to just typing in "GraphicsEnabler=Yes -v" and everything booted up and I had working ethernet, Audio, video.  Mac store and iMessage works.  I haven't gotten iCloud to connect yet.  


So maybe if you try something similar to what I did you will find success.  


I do have one other problem if anyone can help me.  When I plug my primary monitor into the HDMI port it makes my second monitor (which I installed with) turn off and the HDMI video doesn't get to my second monitor.  Any idea why that is?  Maybe there is something I need to do in OS that I am ignorant of or maybe it is a setup issue.  Or maybe I have to reset video resolution.  I don't need Audio thru HDMI, just video and both monitors will have different resolutions.


My org.chameleon.Boot.plist looks like this:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<key>Kernel Flags</key>
<string>npci=0x2000 dart=0</string>

Share this post

Link to post
Share on other sites

Thanks Tom & Aman, yes i will try to mimic your procedure. I get a message at boot that my Nvidia 'ID Device"-"Vendor ID" rom can't be loaded. In my system report Graphics/dispays Device does not show kext loaded. I don't think I made the kext correctly. 


Tom, Do your bluetooh, webcam function as well?

Share this post

Link to post
Share on other sites

I don't have bluetooth or webcam built into my machine.  


I tried to get my dual monitor going on my GeForce GTX 560 Ti so I thought I could run multi beast to start that process.  Everytime I run multi beast it breaks my machine into not booting anymore.  So I must be setting something up wrong in it. I was able to go back into windows and edit by chameleon.plist back to original and copy back my original kext files and it then boots properly.  I'm not sure why multi beast breaks my machine.  I think it has something to do with the kext files because I tried just changing my chameleon.plist back to original and it wouldn't boot until I copied over my original kexts.  


So I still don't have dual monitor figured out yet.  


Which kext file are you trying to update for the device id?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...