Jump to content
Giovanni Verschuren

Lenovo G500s Intel HD4000 problem

Recommended Posts

Hello,

 

As the topic title says. I've a problem with my intel HD4000.

 

 I used Rehabman DSDT Patch for my intel HD4000.

 

But after I did that. It works, but my mouse cursor is gone and some times distorted ..

 

Is there anyone that can help me please!!

 

 

Share this post


Link to post
Share on other sites

try latest version of OSX for better Support e.g 10.9 or 10.8..5 ???they don't need DSDT injection ..

Share this post


Link to post
Share on other sites

read this post inject https://www.hackintoshzone.com/page/apple/articles/how-to/intel-hd4000-and-haswell-igpu-r12

 

inject  IntelCapriFB=a_value from 0 to 11 which gives you better result 

 

not sure will work with 10.8.2 ???try ,test and report back 

Share this post


Link to post
Share on other sites

I tried to booth with IntelCapriFB=3

But no result ;(

 

Not sure what i'm doing wrong

Share this post


Link to post
Share on other sites

not only =3 try from 0 to 11 ,,,

Share this post


Link to post
Share on other sites

I only need to boot wih IntelCapriFB=X right?

Share this post


Link to post
Share on other sites

yes  IntelCapriFB= 0 -11 ( choose between figure )

Share this post


Link to post
Share on other sites

Tried them all, but all dont work.

What I dont understand, cause HD4000 is supported out of the box right?

Intel HD4000, is in some mac models ..

 

What can I do :(

Share this post


Link to post
Share on other sites

yep it's natively supported but sometimes you need tricks to injection ,,SMBios also effects HD4000 and injection of InetlCapriFB in Chameleon or Clover in important...

Share this post


Link to post
Share on other sites

If i post the ioreg. Can you do something with that?

Share this post


Link to post
Share on other sites

hmmm,,post i will try 

Share this post


Link to post
Share on other sites

Okay,

 

here is my ioreg with the DSDT loaded. Which give me the mouse cursor to dissapear 

 

https://www.dropbox.com/s/6gma946pb6tui0j/ioreg.ioreg

Share this post


Link to post
Share on other sites

Do you already have a fix ? :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.66 of $100.00 goal reached.
    Donate Now
×