Jump to content
poseso

Lenovo Y510p GT-750M

Recommended Posts

Can my Nvidia Geforce GT-750M be activated on Mavs 10.9.2 ?

 

I have a Lenovo y510p dual gt-750m.

 

Greetings,

 

poseso

Share this post


Link to post
Share on other sites

@poseso Yes. This card is natively supported by OSX.

Share this post


Link to post
Share on other sites

Ah great!

Share this post


Link to post
Share on other sites

Can my Nvidia Geforce GT-750M be activated on Mavs 10.9.2 ?

 

I have a Lenovo y510p dual gt-750m.

 

Greetings,

 

poseso

Did you manage to install mavericks on it ? I am searching many forums and no clue.

Share this post


Link to post
Share on other sites

@poseso Yes. This card is natively supported by OSX.

Can you confirm if Niresh Mavericks is working with y510p ?

Share this post


Link to post
Share on other sites

Since the hardware says yes, give it a shot.

If you make backups you have nothing to lose after all!

Share this post


Link to post
Share on other sites

So did any one managed to install on y510p? i did install it, but no network neither on lan or wifi... it just doesnt show im connected

 

EDIT: So no one knows?

Share this post


Link to post
Share on other sites

  • Like 1

Share this post


Link to post
Share on other sites

Could you please share a guide how to do it?

Share this post


Link to post
Share on other sites

Hi, any news for nvidia gt 750m? He was able someone to install it?

Intel video card I managed to install.
 

Share this post


Link to post
Share on other sites

Ah great!

Is your laptop working with Mavericks and GT750m SLI?

I have this laptop and I have Mavericks and Windows 8 on it. Mavericks works fine without the second video card, but if I put it in my computer, Mavericks does not start anymore. I dont know what I can do to solve this. :S

Share this post


Link to post
Share on other sites

Lucas I just got it installed on my y510p as well ive got  triple boot going, if you find anything on getting it to boot with the second in let me know. also if you don't have a wifi adapter yet i recommend this one its great works like a chram I just installed the driver reboot and instant internet. http://www.edimax.com/en/support_detail.php?pd_id=347&pl1_id=1&pl2_id=

its only $8! http://www.amazon.com/Edimax-EW-7811Un-Adapter-Raspberry-Supports/dp/B003MTTJOY

Any way it works great but I also cant boot with second card in. I remember getting a nvidia pci7 message or something then it freezes is that what happens to you as well?

Share this post


Link to post
Share on other sites

No one so far managed to install GT750 / 755M. If i start with the second plate (SLI) i have only 64mb video in Mavericks. I am tired of to remove the second card from the laptop when I want to start Mavericks.emoticon-0179-headbang.gif.pagespeed.ce.

Share this post


Link to post
Share on other sites

No one so far managed to install GT750 / 755M. If i start with the second plate (SLI) i have only 64mb video in Mavericks. I am tired of to remove the second card from the laptop when I want to start Mavericks.<script pagespeed_no_defer="" type="text/javascript">//So

So is your Mavericks working with SLI fine? I cannot start mine if I have my second video card inside. If I have my second card inside it always freeze on load screen. My Mavericks just recognize HD Graphics :S. What did you do? I just wanna make that running with both video cards, I really do not care about the memory if it is working. I have windows in dual boot to play games, etc.

Share this post


Link to post
Share on other sites

Lucas, Works but graphics 64 mb. If i remove the card works with 1024MB (1GB).I did nothing, I installed normally. I have windows 7.

 

 

 P.S. I was wrong, I dont have 64 mb. I have 7MB. Using the settings nvidia video card but the laptop sees 0mb :)) FinalCut not go less than 128mb.

image.png

image.pngimage.pngimage.png

Share this post


Link to post
Share on other sites

bogdangepe

Man, I am sry, but I cannot see anything, the pictures are so small, and our video cards have 2GB of RAM each. Just to be sure, you are with your ultrabay video card (second video card - SLI) inside the computer right?

Try to upload the pictures in another website like:

http://programmer.com.br/pgupload/

http://www.imageupload.co.uk/

Share this post


Link to post
Share on other sites
 
I saw, when I selected the pictures I did to make them automatic for web. When I get home I put pictures in high quality. Yes, the video card is in the laptop.(ultrabay)

Share this post


Link to post
Share on other sites

Thank you man.

Did you install it using Unibeast or Myhack?

I used Unibeast and after that I just needed to install the bootloader, for most  things were working except for Sound and Wireless, but I have a wireless usb adapter and I use my bluetooth headphone to listen.

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

If anyone here a wireless sub adapter. Does anyone here know how do I connect to a network which needs login and password (802.1x) to access? i download the driver from realtek, but its software only offer option to type the password of the network and the net of my University requires also a login. Thus, I cannot connect unless if I use cable :S

I also tried to use the Airport Utility from Apple, but it does no recognize my usb adapter :S.

 

This is the link of my university tutorial for apple computers: http://www.wsu.edu/wirelessinfo/wireless/peap2mac.html

 

 

 
I saw, when I selected the pictures I did to make them automatic for web. When I get home I put pictures in high quality. Yes, the video card is in the laptop.(ultrabay)

 

Share this post


Link to post
Share on other sites
Like  that I installed Mavericks.
2-   Install Win32 DiskImage
3-   Burn to usb maverick
4-   restart laptop and press F12
5-   boot from usb(Niresh Mavericks)
6-   press any key and write xpcm-free -f
7-   space next agree :)open Disk Utility select disk/partition select Erase write a name '' Macintosh HD '' format Mac OS Extended (Journaled)
8-   Close Disk Utility
9-   press customise select only CPU fake sensors in rest NOT uncheck anything
10- select disk/partition '' Macintosh HD '' and press install (20-24 min)
11- restart
12- press F12 and boot from disk/partition '' Macintosh HD '' with -x -f -v
13- press space, enter country, id, pass
14- open Terminal (disk/partition '' Macintosh HD '' / Applications / Utilities)
15- write in Terminal '' defaults write com.apple.Finder AppleShowAllFiles TRUE '' enter '' killall Finder '' enter (To return to normal replace TRUE with FALSE)
16- enter in '' Macintosh HD '' delete mach_kernel and paste mach_kernel from attachment
17- open Terminal and write '' sudo -s '' enter / write pass (password is not visible when inserted) enter / write chown 0:0 /mach_kernel   enter/ chmod 755 /mach_kernel  enter / exit / enter
18- replace org.chameleon.Boot.plist and smbios.plist (Macintosh HD / Extra)
19- open kext wizard (Applications / Kext Wizard)
20- install kext from attachment
21- copy from attachment and  paste dsdt. ssdt etc (Macintosh HD / Extra)
22- open and load with Chameleon wizard org.chameleon.Boot.plist and smbios.plist
23- Check if selected squares org.chameleon.Boot.plist (see picture)
24- fix permission with kext wizard (tab 1, select squares enter)
Optional : To be sure, start Kext Utility and automatically repair.
25- restart and boot from Macintosh HD :)
Who wants the files, write me private message.
 
Lucas Reis

I'm sure can be made the video card work. I just do not know how :))

image.pngimage.pngGraphics card was connected permanently (ultrabay)image.pngimage.pnglll   :D  

What wireless usb adapter you have? I have a Edimax EW-7811UN, 802.11 b/g/n

and i have a kit (software and driver)

Share this post


Link to post
Share on other sites

bogdangepe

I did not install mine using the niresh version. I have a Thinkpad Twist running Snow Leopard, so I downloaded Mavericks from Apple Store. I installed mine using Unibeast, and I did not need to use any flags, I just needed to patch my mach_kernel (I think you did the same)  to make this work on Haswell processors (http://www.tonymacx86.com/mavericks-laptop-support/114677-haswell-early-reboot-mavericks-locked-msrs-hp-envy-15-j063cl-i7-4700mq.html). I do not have this DSDT file, may you upload this to me? And may I see your  org.chameleon.Boot.plist and smbios.plist files?

 

Here is my org.chameleon.Boot.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>EthernetBuiltIn</key>
	<string>Yes</string>
	<key>Graphics Mode</key>
	<string>"1920x1080x32"</string>
	<key>GraphicsEnabler</key>
	<string>No</string>
	<key>HDAEnabler</key>
	<string>Yes</string>
	<key>HDEFLayoutID</key>
	<string>03000000</string>
	<key>IGPEnabler</key>
	<string>Yes</string>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Kernel Flags</key>
	<string> nvda_drv=1</string>
	<key>Legacy Logo</key>
	<string>Yes</string>
	<key>Timeout</key>
	<string>2</string>
	<key>UseKernelCache</key>
	<string>Yes</string>
</dict>
</plist>

and my smbios.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>SMfamily</key>
	<string>Mac Pro</string>
	<key>SMproductname</key>
	<string>MacPro3,1</string>
	<key>SMboardproduct</key>
	<string>Mac-F42C88C8</string>
	<key>SMserial</key>
	<string>G8802VAT5J4</string>
	<key>SMbiosversion</key>
	<string>MultiBeast.tonymacx86.com</string>
</dict>
</plist>

And here is the print screen of my modules and extensions folders:

 

Modules: http://goo.gl/PYY8tC

Extensions: http://goo.gl/nZW3CJ

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.66 of $100.00 goal reached.
    Donate Now
×