Jump to content
Fernando Rodrigues Fersoft

Niresh Maverick 10.9.0 on my Desktop AMD 8 core+ATI 5890+16GB+Gigabyte motherboard 100% OK

Recommended Posts

@ There are various topics on the forum regrading this issue. Consider yourself lucky that you got the Appstore and itunes working !

Share this post

Link to post
Share on other sites

You know I am having the same problem.   I succesfully updated to 10.9.2 after copying my mach_kernel and replaceing the extensions folder back.  Everything boots up fine.   However, just like you I can access iTunes, iBooks, AppStore, everything except iCloud or iMessage.  Which I would really like to have for my calander.    I have tried everything as follows:


-nvram file lib- fail

-efi option-  However since I have graphicsenabler=Yes for my Nvidia graphics, it causes me to have a blank screen.  I did however add the EFI for the cards but still does not work.

-sever different UID from smbios- I tried several different models and seriel gens and still no avail.  

-deleted network prefs and re-added network- fail

-added wifi adapter and iphone tether- fail

-added to DNS- fail

-PlatformUID.kext- fail

-iMessageFix from Niresh Download- fail


I have pretty much tried everything except migration tool, which in order to do that I would have to take my pc down to where my other hackintosh is that works awesome as an intel bases one.   Attempt to migrate from there but I am trying to avoid having to do that because it is a huge hassle.   If anyone has any other ideas I would be very greatful to get this working.    I have tried several different ways to get my AMD HAckintosh working and Niresh was by far the best solution for it.    So I really appreciate everything you guys do and look forward to hearing back from you.  


Current Specs are

AMD FX - 8350 Black Edition 8-core at 4.33ghz

2x EVGA 560 Ti 2048mb

Asus Sabertooth 990fx Ver 1.0

Sandisk SSD 120GB For Mavericks Boot

Toshiba SSD 128GB for Windows 8.1 Boot

1TB Seagate for Windows

and Soon a 1TB additional for Mavericks

8GB of Ram


UPDATE 1 - So I managed to do a migration from my other mac to this one and now icloud works great.  Every now and again it will ask me for my password but thats ok.    The only thing though is that Imessage now is connected with my account, but says inactive next to it.    I tried closing the app and re-open it and it then says failed activation again.   So until there is a clear fix I can just use my phone to message right now which is fine or use remote messages either way I am just glad to get my icloud working.    Next just need to figure out how to get the usb working after sleep.   Will not work at all even if I unplug the the keyboard and plug it back in.    I also have no pll overvoltage setting in my bios so I am at a lost at this point

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...