Jump to content

Recommended Posts

Hi 

Hope I'm posting into the correct forum, i last night installed Niresh 10.9. All went smoothly and I'm gad to say i got a 3/4 working Hackintosh. my slight problem is my Graphic card (Amd 7650M) will only out put to my hdmi. but whilst it is on there i got full capabilities. I was wondering if anybody could be as kind enough to help through this phase.

 

My Laptop Spec 

SONY VAIO SVE1315C5E

  • 8gb Ram
  • Amd 7650m 2gb
  • I5 3rd Gen processor 
  • 120GB SSD

Share this post


Link to post
Share on other sites

Just a small update. By using clover as my bootloader i know have native resolution but have no QE/CI available any body available to help? like i said HDMI to tv gives me QE/CI which is quite annoying. This is all that is not working at this moment in time. any help would be greatly appreciated

 

Share this post


Link to post
Share on other sites

Is there anychance of help on this guys i will donate if i can get this working would be really appreciated! thanks again

Share this post


Link to post
Share on other sites

@

1) Install Clover Configurator, Open it, Go to File > Open > Your hard disk > EFI > Clover > Config.plist

2) Go to the graphics tab and check Load VBios, Inject ATI and Inject EDID

3) Set Video Ports to 3 and Save.

4) Download this folder. In the folder, got to  Clover and copy the ROM folder to the Clover EFI folder on your hardrive.

5) Reboot

 

If this gives you a black screen, reboot and also select Patch VBios

If this also doesn't  work try deleting the ROM folder 

If that also doesn't work try injecting your EDID and device id with clover (highly recommended you inject your EDID)

Share this post


Link to post
Share on other sites

How would i Inject device id in clover ? ive injected edid and tried almost anything

Share this post


Link to post
Share on other sites

This is extremely frustrating as it works fine on my hdmi which is kinda confusing

Share this post


Link to post
Share on other sites

@ In clover configurator, Graphics tab > FB Name > Type Pondweed and enable all options as is in the first reply

Did you inject EDID as shown in the video ?

Be sure to select the config.plist file by going to File > Open > PathtoClover > Config.plist

 

The reason why it is outputting only HDMI video is because you have injected a wrong device personality.

Injecting ATI device id's in clover usually results in a Kernel Panic

Edited by Devonic

Share this post


Link to post
Share on other sites

Did you get this working.
I have the 7650m 2gb card in my sony and I get it to output on the screen @ 1080p, but no QE/CI.
It shows the card but with 7Mb RAM.

I've tryed the ROM file (Blackscreen) , but I notice talk about injecting EDID - What is this?
I've ticked / unticked plus text options within the Clover Configurator, but still no luck.
It's the last thing to fix.

Share this post


Link to post
Share on other sites

4 years later...

 

Hallo!

 

Well, I am in similar situation. I have AMD7650M with 1GB VRAM in my HP8570p. High Sierra successfully installed, all works except for the GPU - shows only Basic display with 5MB - screen flickers.

 

1. temporally installed Win 7 to grab my 1600x900 green EDID raw data - looks like this:

00FFFFFF FFFFFF00 06AFEE11 00000000 00120104 90221378 02E4E5A0 59579226 0D505400 00000101 01010101 01010101 01010101 01016432 40966284 3230402A A40058C1 10000018 98214096 62843230 402AA400 58C11000 00180000 00000000 00000000 00000000 00000000 00000002 000C49F9 0A3C661B 2A396620 20200001

 

2. temporally  installed Ubuntu 18.x.x to grab my GPU ROM file - successfully dumped 65kB vbios.rom

 

3. Get AMD FrameBufferUtility (AMDFBU)

- inserted my bios.rom

- recognised my PCI ID 1002:6841 from vbios in AMD6000Controller with 5 video outputs (LVDS, DP, DP, DP high res, VGA), suggested to use Pondweed FB, so I disabled 1 DP and the old VGA

- generated ATI connectors data and ATI connectors patch >>>> put it all in Clover

 

4. Clover 4678

- inserted vbios.rom in ROM folder

- selected Load VBIOS, Patch VBIOS, Inject ATI (RadeonDeInit not selected)

- patched AMD6000Controller with AMDGPU-provided connectors data

- selected InjectEDID and pasted the code above

 

After restart, AMD 7650M is recognised but still with only 5 MB of VRAM.

 

Any ideas? Please, help. 

Share this post


Link to post
Share on other sites

Go to amd osx website download os x for amd pc. 

Share this post


Link to post
Share on other sites
14 minutes ago, Eric1973 said:

Go to amd osx website download os x for amd pc. 

Hallo Eric! Thank you for your input. Could you please post a link to what you suggested me to download? Will appreciate that! And will let you know the outcome. 

 

Regards 

Share this post


Link to post
Share on other sites

I did not see you are using Amd laptop. I thought you had AMD desktop pc. I have A8 7600  and Radeon HD 5450. I had no problem installing OS X Sierra. I do not think you could do anything with integrated gpu. Especially on AMD laptop. But you could go here www.amd-osx.com and ask around. They will help you. I havd amd laptop as well and could not install os x. Good luck.

Share this post


Link to post
Share on other sites
1 hour ago, Eric1973 said:

I did not see you are using Amd laptop. I thought you had AMD desktop pc. I have A8 7600  and Radeon HD 5450. I had no problem installing OS X Sierra. I do not think you could do anything with integrated gpu. Especially on AMD laptop. But you could go here www.amd-osx.com and ask around. They will help you. I havd amd laptop as well and could not install os x. Good luck.

Hi!

 

As I wrote before... there is AMD graphics only in my HP laptop (HP8570p). I did not write a single letter about my device being an AMD-based PC. But thank you anyway! I will ask them there...

 

Cheers, bye!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $21.95 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

  • Download Statistics

    • Files
      855
    • Comments
      2,150
    • Reviews
      2,619

    Latest File
    By Niresh

    236    2

×