Jump to content
PierreDa

<solved> Must boot from Niresh USB key with flag npci=0x2000

Recommended Posts

Hi,

 

I succeed to install Mavericks.

System was booting without problem to login.

 

BUT

 

The problem is since I try to have my ethernet and graphic working with Multibeast !

 

Now if I boot normally, i'm stuck on the gry screen with Apple logo.

 

The only way to boot is to boot with my USB key (Niveresh) and boot with flag npci=0x2000 !

 

Any solution to that?

 

Thanks a lot

 

Best regards

 

Pierre

Share this post


Link to post
Share on other sites

Same problem here....! But in my case, it is working without any boot flag. Just have to insert USB and boot from the drive. I think there is a problem in the bootloader.. I am aslo finding for solution. Kindly help..

Share this post


Link to post
Share on other sites

Same problem with me .

I found to editing the boot loader during setup and I reinstalled the OS it got it working fine.....

 

option 2

 

Try to edit boot loader using Linux edit the boot loader and the problem can be fixed .

Am trying on creating a script to fix this problem

 

 

 

Share this post


Link to post
Share on other sites

Yes I suppose we can edit a "system boot/ini file" where all the flags are set!

But I'm not sure which one ;-)

Someone to give the info?

How to edit the file? Using terminal/sudo and "vi" ?

 

Last U suppose that the ncpi flag is related to my graphic car (in this case not working). Placing a new graphic card (I'll buy a nvidia GT640) will correct his....

 

Regards

Share this post


Link to post
Share on other sites

edit your /Volumes/Macintosh HD/Extra/org.chameleon.Boot.plist

  • Like 1

Share this post


Link to post
Share on other sites

Have you try and reinstall the chameleon bootloader to the latest version and also you can

Input the npci= bootflag into chameleon plist file that way you dont have to put it

All the time you restart the pc

  • Like 2

Share this post


Link to post
Share on other sites

I finally reinstall from scratch!

It's working.

 

If I remember I tryed to reinstall bootloader with no success.

 

For the rest, If you can take a look at my other posts ... really can't understand

 

Thanks

Share this post


Link to post
Share on other sites

You welcome

Share this post


Link to post
Share on other sites

same for me -f npci=0x2000

Share this post


Link to post
Share on other sites

Goto your Extra

 

And edit your org.Chameleon.Boot.plist to look like :

 

 

<key>Kernel Flag</key>

<string>npci=0x2000</string>

 

 

Insert above lines between <dict> ... </dict>

Note : If you have other boot flags between <string></string> then let them be just maintain a blank space among each other.

 

There are many many guides on net how to edit a flag plz try that before reviving an old thread.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $17.56 of $100.00 goal reached.
    Donate Now
×