Jump to content
nanerasingh

Graphics driver problems for INTEL HD 4000 + Nvidia GT620M On dell

Recommended Posts

hi,i have my dell vostro INTEL HD 4000 + Nvidia GT620M on intel chipset HM75 7 series.

I can normaly boot to niresh mac 10.8.2 but only with hd4000 if i select custom install with move nvidia driver to extension options.

i am a designer and i need my nvidia card to work for my software.

please help me how to enable my nvidia card.please guide me.i dont know too much about hacking or any kind of editing.

 

Share this post


Link to post
Share on other sites

hi,i have my dell vostro INTEL HD 4000 + Nvidia GT620M on intel chipset HM75 7 series.

I can normaly boot to niresh mac 10.8.2 but only with hd4000 if i select custom install with move nvidia driver to extension options.

i am a designer and i need my nvidia card to work for my software.

please help me how to enable my nvidia card.please guide me.i dont know too much about hacking or any kind of editing.

"Most laptops (and I guess yours to) have the feature to switch between the internal graphics (energy saving) for normal use and the stronger graphic card (energy consuming but powerfull) when you are playing games or doing graphic intensive work.

This works good under windows, but this mac distribution has problems because your computer switches between the 2 graphic cards.

Mac os supports a certain amount of hardware which use internal graphics and graphic card switching.

But laptops like yours are not supported to switch between the cards. I know a lot about this because I had the same issue with my previous laptop, and I looked on every forum searching for the answer."

 

The only solution is to shut off the graphic switching (called Optimus technology with Nvidia cards), or to use a strongly modified kext file.

Try to go in your bios, and if there is an option to disable optimus technology/disable internal graphics, change that.

I had the same problems with my previous laptop, but was not able to fix it because I couldnt disable optimus technology.

Hopefully somebody else on this forum has a fix for this or hopefully the next release will support this.

Share this post


Link to post
Share on other sites

Thanks for reply

I checked in my bios but there is no options to switch off.

But i hope someone help me for this.i hope there will be some solution for this.

Best reply will be highly apreciated

Share this post


Link to post
Share on other sites

try to use or enable hd4000 ,nvidia mobile chipset will not work ,wasting time upon is worthless ,,have a happy hackintosh

Share this post


Link to post
Share on other sites

I'm using fresh niresh mavericks installation, by default the HD3000 detects as primary GPU, when I checked the system info, i was amazed that the Nvidia Geforce 620M was detected, I wonder if this can be set as default, i tried PCIRootUID=1 nvda_drv=1 GE=No and as usual it doesnt works. 

post-279-0-84656400-1400790553_thumb.png

Share this post


Link to post
Share on other sites

this is only for detection it can't works due tp nvidia optimus is not supported in mac 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.30 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • I get this message no matter what I do, I've tried changing my SMBIOS to a newer model to no avail. Anyone no how to get the second install boot to work?
    • This is my first time doing Hackintosh. I've several other machines running Mac using UniBeast and Multi beast. I wanted to try Hackintosh Vanilla. So far, no luck. I followed the Guide and MacPwn Mojave Guide. 
    • Hello! I wanted to install MacOS High Sierra, but the SSD does not appear in Disk Manager. I have a Samsung Pro 840 250GB. Is there a Driver for Intel Gigabit 82579LM Network LAN for MacOS High Sierra?
    • This is my very first post and have looked around the forums to my question but I wasn't able to find the exact specifics that I need. This is my very first windows/mac dual boot project. I chose to attempt high sierra and I hope I am posting in the correct area. High Sierra seemed to be the newest that is possibly more stable than Mojave so I chose that. I'm reaching out to the more advanced builders and experienced people. I'm currently running Win 10 as of now and bought a separate SSD to install a macOS on. Before I invest time and energy into this. I'm wanting to get the best recommendations on what OS I should choose , if my hardware will be up for the task and my best plan of attack. I'll be honest I'm not ready to bang my head on the keyboard for hours. I've been there and done that.  My hardware was some of the best at its time in 2011 and I'm not 100% confident it will work with a more up to date macOS I'm also concerned about drivers for my GPU.  All input is welcomed   Here are my current specs:   CPU
          Intel Core i7 2600 @ 3.40GHz    28 °C
          Sandy Bridge 32nm Technology
      RAM
          8.00GB Dual-Channel DDR3 @ 668MHz (9-9-9-24)
      Motherboard
          ASUSTeK Computer INC. CG8350 (LGA1155)    26 °C
      Graphics
          NS-24E730A12 (1842x1036@60Hz)
          1023MB NVIDIA GeForce GTX 560 Ti (NVIDIA)    31 °C
      Storage
          3726GB Western Digital WDC WD40EFRX-68N32N0 ATA Device (SATA )    25 °C
          111GB PNY CS900 120GB SSD ATA Device (SATA (SSD))    33 °C
          931GB Seagate ST31000528AS ATA Device (SATA )    30 °C
          3726GB Western Digital WDC WD40EFRX-68N32N0 ATA Device (SATA )    27 °C
      Optical Drives
          HL-DT-ST BD-RE BH12LS35 ATA Device
      Audio
          NVIDIA High Definition Audio 
    • Hi! Everything seems to install ok, but after reboot, it just says Disk Booth Failure Insert system disk and press enter.. Don't have a clue about what can I do!   Francisco
  • Download Statistics

    • Files
      855
    • Comments
      2,148
    • Reviews
      2,612

    Latest File
    By Niresh

    184    2

×