Jump to content
viserbapaolo

USB Issue AMD FX Processor

Recommended Posts

@Niresh I tried to install it today. Specs:

CPU: AMD FX-4100
Motherboard: Gigabyte Technology Co., Ltd. GA-990XA-UD3 (Socket M2)
Graphics: 4096MB ATI AMD Radeon HD 6570 (Sapphire/PCPartner)
Monitor: Acer P225HQ (1920x1080@60Hz)
Network: Controller Realtek PCIe GBE Family
Peripherals: PS/2 Keyboard and USB Wireless Mouse

Booting without boot-flags results in a PCI error.
Using the following boot-flag I can go on, but the installation suddenly outputs an infinite log regarding AppleUSBHostController that went on for like 5 minutes until I stopped it.

npci=0x3000

Error screenshot:
miGmL3r.jpg

Using Yosemite Zone I once booted into the installation with:

/amdfx npci=0x3000

However I can't find an equivalent to /amdfx in High Sierra Zone.

Any help?

  • Like 2

Share this post


Link to post
Share on other sites

@viserbapaolo 

You have only two options:

If you are using Clover use

kcsuffix=bronya or kcsuffix=shaneee

If you are using Chameleon

Kernel=kernel.bronya or Kernel=kernel.shaneee

 

Is this USB error happening after installation or Before installation?

Share this post


Link to post
Share on other sites

@Niresh

The error is happening before installation, and I will try with those boot-flags.
However, how can I know which bootloader I'm using? I just put the boot-flags as soon as I'm able to do it, without changing anything. I think I'm using the default one.

  • Like 1

Share this post


Link to post
Share on other sites

@viserbapaolo I think you are booting in Legacy mode, After selecting USB as boot source keep pressing Number 6, which will load Clover bootloader
Clover usually patches many issues on the fly better give it a try.

Keep me posted

  • Like 1

Share this post


Link to post
Share on other sites

@Niresh 

I was most definitely booting in legacy mode.
I tried the boot-flags you suggested with chameleon and clover, but the error is still there. Using clover it just shows up in native resolution of 1920x1080.

Share this post


Link to post
Share on other sites

Have the same exact issue here. An AMD FX processor (Amd FX 4300) and a constant flood of error messages about the Apple USB Controller. Granted I'm new to this stuff, but its frustrating.

Niresh, your fixes don't work. Just like what Viser said, the only difference is the resolution. :(

Share this post


Link to post
Share on other sites

@Niresh, Many thanks to Niresh, I Have a same problem keyboard and mice are not work and make me stuck in Language selection at Before Installation

Flag :

kernel=amd npci0x2000

Regards, :wink:

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, hamid_smd said:

@Niresh, Many thanks to Niresh, I Have a same problem keyboard and mice are not work and make me stuck in Language selection at Before Installation

Flag :

kernel=amd npci0x2000

Regards, :wink:

Thank you for this,  I'm glad you got it working just fine! 

However my problem still remains 😅

Share this post


Link to post
Share on other sites
13 hours ago, The Dark Side said:

Have the same exact issue here. An AMD FX processor (Amd FX 4300) and a constant flood of error messages about the Apple USB Controller. Granted I'm new to this stuff, but its frustrating.

Niresh, your fixes don't work. Just like what Viser said, the only difference is the resolution. :(

I'm trying different boot-flags, but still nothing.

Let me know if you find a solution.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...